mooseyaka: (Default)
[personal profile] mooseyaka
Решил я нонче на свой раритет установить убунту, та что бета, 9.10.
Ченьжлог я приводить не буду, кому прям любопытно - почитайте на оффсайте.

Суть псота в том, что у меня кривой DVD-rom, в следсвии чего я не могу нормально записать убунтоидные диски и с них поставить. И флешку я забыл у Лехи, когда ездил восстанавливать комп.

Решение - установить через unetbootin.
Реально - мучить wubi, еще что-то, думать как загрузиться из образа скачанного...
Юнетбутин решит эту проблему.

Дальше нетривиально - сначала я пробовал вариант с подключением iso - не получилось, но ходы сделаны.
По ходу пьесы - создана папка boot, в нее положены загрузчик и образ, прописал загрузчик grub4dos в boot.ini, положил в корень c: menu.lst.
Ладно, запускаю ЮНБИ, скармливаю образ беты 9.10 убунты для х64 АМД, альтернативный, жду, он отрабатывает...
Ребут.

Загрузка, начало установки, опять гонит на отсутсвие диска. Я удивился, потому что как правило если ты что-то сменил - проблема выглядит уже по другому.
В общем - догнал не сразу, но menu.lst в корне диска я оставил зря - переустановленный grub4dos нетбутином тем не менее искал его там одним из первых, и естественно находил.
Удалил, перезагрузился, все дела... Теперь - по умолчанию загрузчик загружает что-то не то, что именно сейчас не скажу, но в общем установщик опять ссылается на сидюк, хотя не должен - это факт.
Ребут, нажимаю эскейп, появляется менюшкасмотрю по командам что он грузит. В итоге, выбор по дефолту стоит не на install, а на чем-то еще. Запуск инстала - запускается текстовый режим. Процесс  идет.

Перепитии в процессе установки описывать не буду - сам дурак, там ничего страшного по идее...
А вот с загрузчиком оказалось немного сложнее.

В 9.10 воткнули grub2; во первых - не подцепил винду - следствие текстового режима, подозреваю.
Во вторых - изменился синтаксис параметров загрузчика.

Ну ладно, бунту грузится, гуглим, находим правильные параметры для нового "ГРУБ2-ияна", прописываем...
С параметрами set root(hd0,0) не загрузился. Странно, потому что винда на первом разделе стоит, следовательно... По дефолту все должно было.
А вот с hd0,1 - все загрузилось. Будем мучать эту убунту дальше,
From:
Anonymous( )Anonymous This account has disabled anonymous posting.
OpenID( )OpenID You can comment on this post while signed in with an account from many other sites, once you have confirmed your email address. Sign in using OpenID.
User
Account name:
Password:
If you don't have an account you can create one now.
Subject:
HTML doesn't work in the subject.

Message:

 
Notice: This account is set to log the IP addresses of everyone who comments.
Links will be displayed as unclickable URLs to help prevent spam.

January 2013

M T W T F S S
  123456
78910111213
14151617181920
21222324252627
28293031   

Most Popular Tags

Style Credit

Expand Cut Tags

No cut tags
Page generated 24 Oct 2017 12:07 am
Powered by Dreamwidth Studios